ERRORMSG: Failed to update the Logger Address Book

Article ID: 040527sab
Last Reviewed: July 10, 2023

The information in this article applies to:

Symptoms

When Pronto is started the message”Failed to update the Logger Address Book“is shown, followed by the message Unable to open the Logger Address Book. Following this Pronto opens, but Address book and Logger access functions are not available or do not work.

Cause

This problem is due to Pronto not being able to open the Logger Address book for writing. The Logger Address book is a file called PRONTO.ABK.

Resolution

Check the following:

  1. The file PRONTO.ABK is present on the system (it is normally installed into the same directory as PRONTO.EXE).
  2. It does not have the read only flag set.
  3. The Logged in user has write access into the directory in which it resides.
    If the Logged in user does not have write access to the file, an administrator will need to move this file to a location where the user does have write access.

Further Information

The Logger Address Book is System Global, that is, on a Machine with multiple copies of Pronto installed, all Pronto versions will use the same PRONTO.ABK.

To check which PRONTO.ABK is in use look in the registry key HKEY_LOCAL_MACHINE\Software\Ranger\Pronto for Windows\Logger for the value DatabaseFileName.
(or possibly the same Key under HKEY_CURRENT_USER )

References

APPNOTE: Setting up Pronto for Windows for use by a restricted user