PROBLEM: Pronto is slow or unresponsive when a graph is zoomed or redrawn

Article ID: 120927sab
Last Reviewed: July 10, 2023

The information in this article applies to:

  • Pronto for Windows all versions 5.00 to 5.71 and 6.00 later running on Windows Vista, 7, 8, 10 or 11 (both 32 and 64 bit).

Symptoms

In Pronto for Windows, when zooming or performing another action that causes a graph to be redrawn, may hang or go unresponsive for a period of a few seconds upwards.

Cause

The Database drivers are running out of memory.
When memory buffer space is limited, readings are retrieved in many small chunks instead of a couple of large chunks. Using many small reads is inefficient and with a large block of readings can take a very long time.

Each time a graph is redrawn Pronto must access the database to retrieve the readings for each trace present on a graph, when zooming if the graph has autoscaling enabled, the readings are retrieved twice, once to find the limits to use for the graph and again to retrieve the readings for drawing.

Resolution

Increase the amount of memory available to the ODBC database drivers by following these steps:

On 32 bit Windows (11/ 10 / 8 / 7 / Vista)

  1. Ensure Pronto for Windows is closed.
  2. On the Windows Taskbar click on the START button and select RUN.
  3. On the Run dialog type in “ODBCAD32.EXE” and select OK to open the ODBC Administrator.
  4. On the ODBC Data Source Administrator dialog select the USER DSN tab.
  5. On the USER DSN tab select the entry Pronto Projects 32bit and click on CONFIGURE.
  6. On the ODBC Microsoft Access Setup dialog click OPTIONS>> in the bottom right to open the Driver section.
  7. In the  Driver section increase the Buffer Size from 8192 to (for example) 32768.
    This changes the memory available from 8 MB to 32 MB.
  8. Click on OK to close the ODBC Microsoft Access Setup dialog.
  9. Click on OK to close the ODBC Data Source Administrator dialog.

On 64 bit Windows (11/ 10 / 8 / 7 / Vista)

The default buffer size is already 32768. It is unlikely this will need to be increased unless large Logger recordings are present where only one or two channels were turned on.
If it is felt that the setting needs to be changed, follow the procedure below:

  1. Ensure Pronto for Windows is closed.
  2. Launch the 32 bit version of the ODBC administrator.
    On Windows 10/11, type “odbc” into the Windows search box then selecting “ODBC Data Sources (32-bit)”
    On Windows 7 and earlier, open the RUN dialog and browse to the location of odbcad32.exe
    On 64 bit Windows, the 32 bit version is typically here c:\Windows\SysWOW64\odbcad32.exe
        (Note: on 64 bit Windows there is also a 64 bit version of the administrator here: c:\Windows\System32\odbcad32.exe but it is unable to change settings in the 32 bit drivers. If this version is used it will give the error: The setup routines for the Microsoft Access Driver(*.mdb) ODBC driver could not be found.
  3. On the ODBC Data Source Administrator dialog select the USER DSN tab..
  4. On the USER DSN tab select the entry Pronto Projects 32Bit and click on CONFIGURE.
  5. On the ODBC Microsoft Access Setup dialog click on OPTIONS>> in the bottom right to open the Driver section.
  6. In the Driver section increase the Buffer Size, from 32768 to (for example) 131072.
    This changes the memory available from 32 MB to 128 MB.
  7. Click on OK to close the ODBC Microsoft Access Setup dialog.
  8. Click on OK to close the ODBC Data Source Administrator dialog.