PROBLEM: Scheduled Events not performed after clock changed

Article ID: 011218sab
Last Reviewed: July 10, 2023

The information in this article applies to:

Symptoms

A scheduled event is not performed after the computer time is changed backwards by a large amount.

Cause

Pronto for Windows calculates the next time to perform a scheduled event upon completion of each event. If the computer time is subsequently moved backwards the time at which the scheduled event will be performed remains unchanged.

For example:

A Scheduled event is specified to run every hour on the hour.

The event is run at 09:00 on 18 December 2002.

Once the event has completed Pronto for Windows calculates the next time to run the event to be 10:00 on 18 December 2002.

If the computer time is then moved back to 18 December 2001 the event will still not be performed until 10:00 on 18 December 2002.

Resolution

Perform the following steps:

  • Select the menu item LOGGER then SCHEDULED EVENTS.
  • On the Scheduled Events dialog add a new scheduled event with the same details as the original.
  • Delete the original scheduled event.